Gettign started from FSAI test webinar

Good Afternoon,

I am working on an FSAI overall project using Carmaker and I am struggling to understand the initial concepts behind the programming that was done in the IPG FSAI test webinar due to the fact that LiDAR on the computer I am running the programme on is not working, which I have also expressed concerns in the forum and I’ve tried everything that been suggested.

I made an attempt to follow the test webinar however it is very difficult to follow along with it due to how small the terminal screen is. To sum up this email: I really need help getting started and would appreciate some guidance on how to do so.

PS: I am using carmaker for my dissertation

Kind Regards
Tolu Egberongbe

I believe how to get started is also in the documentation provided with the FS-AI package.

Hello Tolu,

It is not an ideal starting point, but it would be good to verify that the project at least works without any of the GPU sensors. Please try to disable the LiDAR and the Camera RSI sensors from the “Activate” button in the Sensor Mountings tab.

By doing that at least you can open the project, run it, and check whether everything else works correctly.

Afterwards, the second thing to try is to start a normal CarMaker session completely independent of all the ROS stuff and the FSAI project. For this project, we use a “CMStart” shell script to launch CarMaker with a bunch of additional options. Instead, open CarMaker from its basic executable. In Ubuntu, that would be in /opt/ipg/carmaker/linux64-10.1/bin and it should be called “CM”.

Create a new project and open one of our example test runs that contains a GPU sensor. I would recommend the RadarRSI_Motorway example found here:
Product Examples/Examples/BasicFunctions/Sensors/RadarRSI_Motorway

It would be helpful to know if the issue is with the FSAI package or the basic CarMaker setup.

As mentioned above, the FSAI-specific documentation could also be helpful and can be used instead of the webinar. It is a little bit hidden inside the main project, but it can be found at the following location:

I’ll try to investigate the other issue that you raised which was GPU-specific. As far as I remember you had an A4000 RTX, which should be compatible with CarMaker, thought sometimes the professional level cards are not compatible with some of the sensor features.


One additional thing that I wanted to do last time was to post an actual screenshot of the NVidia drivers I use:

I tend to stick with the proprietary and tested drivers because the other ones have causes me many headaches in the past.

Thank you for the reply. I have already disabled the LiDAR and the camera RSI depth and everything works perfectly. I am honestly not sure what the problem but i think its with the carmaker setup because from the webinar, i noticed that on ipg movie, it doesn’t show the steering angle information and speed dial. When I tried running with the LiDAR it would initially say that the camera RSI couldn’t open socket for GPU sensor2 with the LiDAR not supported on current graphics card. We’ve tried installing new drivers but it still didn’t work. Thank You for the assistance, I will be moving forward with the guidance you given me.

Morning Tolu,

I had a word with our developers this morning. I can confirm that the A4000 is supported, but with CarMaker 10 as initially suggested, the 470 drivers will not work. This is also the reason you are getting an “unsupported GPU” message.

You mentioned in the previous email that Ubuntu will not let you downgrade to 460. Is it possible for you to purge your existing NVidia drivers and try to install the proprietary 460 driver on your machine~?

Hi Bogomil,

I tried that as well but for some reason it would only let me install the 470 driver and none of the drivers before it regardless of which version it was.

Hi Tolu,

Which Ubuntu version are you using?
I had to go on the official Nvidia website to make sure that the A4000 is compatible with drivers prior to 470. It looks like it is:

You might have to find a way to manually download the package of 460 and install it if setting the correct remote repository does not work.

I know it doesn’t help you, but I’m using Ubuntu 18.04 and most of the development has been done and tested in 18.04 with a laptop RTX 2070.