CM4SL project unable to unload mex file after simulation

When I create a new CM4SL project (I used Carmaker 9,10.0.1, 10.2) and use the generic.mdl to launch Carmaker and run a simulation, I can only run the simulation once. The second time I press Start on Carmaker GUI (Or start sim on Simulink), I get this message. Over last year I have had an open ticket with IPG but this remains unresolved. I have tested this on multiple laptops in our organisation and also brand new laptops that do not have our organisation’s firewalls/antivirus installed and have been able to replicated this issue.
Screenshot 2022-04-07 100202

I have tried clear mex and all other related mex clearning commands in Matlab. But the libcarmaker4sl.mex cannot be unloaded from Matlab.
Only way to resolve this has been to restart Simulink.
Is anyone else facing this issue?

1 Like

Hello ,Now I have occurred the same question in my project, Could you tell me how did you solved this problem?My software is Carmaker10.2 & Matlab20b,Thank you very much sincerely. Maybe you can send the answer to my personal Email on “